Commodities Order Placement Issues - MCX

Incident Report for FYERS Status Page - Prod

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 23:30 IST

Investigating

Due to a technical issue from the MCX end, some clients may face order placement issues. We are actively working with MCX to resolve this at the earliest.

We regret the inconvenience caused.
Posted Mar 09, 2026 - 19:14 IST
This incident affected: Exchange connectivity (Multi Commodity Exchange (MCX)).