MCX feed and Order placement issue

Incident Report for FYERS Status Page - Prod

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 10:18 IST

Investigating

Due to some intermittent issue from MCX exchange end users were not able to get real time feed and unable to place orders. This issue is faced across all brokers. We are coordinating with exchange to resolve this issue on priority.
Posted Jul 23, 2025 - 09:15 IST
This incident affected: Exchange connectivity (Multi Commodity Exchange (MCX)).