Connectivity Issue at MCX Exchange

Incident Report for FYERS Status Page - Prod

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 13:30 IST

Investigating

Due to connectivity issue at MCX Exchange, Trading will resume tentatively after 01:00 PM.
Posted Oct 28, 2025 - 09:00 IST
This incident affected: Exchange connectivity (Multi Commodity Exchange (MCX)).